求勝之路 買賣線 通達信主圖指标 源碼 貼圖(圖文)

時間:2019-08-10 11:55:26 作者:admin
後台-系統-系統設置-擴展變量-(内容頁告位1-手機版)

求勝之路 買賣線 通達信主圖指标 源碼 貼圖

求勝之路 買賣線 通達信主圖指标 源碼 貼圖


PL5:=IF(PERIOD>=7,ZIG(3,1),IF(PERIOD=3,ZIG(1,2),ZIG(1,2)));
{S說明: 如果周月以上的選5%轉向,如果日線選3%轉向,如果日線以下周期選2%轉向 }
PL10:=IF(PERIOD>=7,ZIG(3,30),IF(PERIOD=3,ZIG(1,10),ZIG(1,10)));
{S說明: 如果周月以上的選10%轉向,如果日線選5%轉向,如果日線以下周期選4%轉向 }
PL20:=IF(PERIOD>=7,ZIG(1,10),IF(PERIOD=3,ZIG(1,30),ZIG(1,20)));
{S說明: 如果周月以上的選15%轉向,如果日線選8%轉向,如果日線以下周期選7%轉向 }
EN1:=PL5>REF(PL5,1) AND REF(PL5,1)<=REF(PL5,2) AND REF(PL5,2)<=REF(PL5,3);
EX1:=PL5<REF(PL5,1) AND REF(PL5,1)>=REF(PL5,2) AND REF(PL5,2)>=REF(PL5,3);
EN2:=PL10>REF(PL10,1) AND REF(PL10,1)<=REF(PL10,2) AND REF(PL10,2)<=REF(PL10,3);
EX2:=PL10<REF(PL10,1) AND REF(PL10,1)>=REF(PL10,2) AND REF(PL10,2)>=REF(PL10,3);
EN3:=PL20>REF(PL20,1) AND REF(PL20,1)<=REF(PL20,2) AND REF(PL20,2)<=REF(PL20,3);
EX3:=PL20<REF(PL20,1) AND REF(PL20,1)>=REF(PL20,2) AND REF(PL20,2)>=REF(PL20,3);
走強1:=BARSLAST(PL5<REF(PL5,1));
走弱1:=BARSLAST(PL5>REF(PL5,1));
走強2:=BARSLAST(PL10<REF(PL10,1));
走弱2:=BARSLAST(PL10>REF(PL10,1));
走強3:=BARSLAST(PL20<REF(PL20,1));
走弱3:=BARSLAST(PL20>REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走強2),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走強2),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走強3),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走強3),0);
DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
DRAWTEXT(EN1 AND DTJZ5=1,L*0.98,'(A)'),COLORFFFF00;
DRAWTEXT(EX1 AND DTJD5=2,H*1.02,'(B)'),COLORFFFF00;
DRAWTEXT(EN2 AND ZTJZ5=1,L*0.98,'(C)'),COLORFFFF00;
DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJD5=1,H*1.02,'⑴'),COLOR0000FF;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2,L*0.98,'⑵'),COLOR0000FF;
DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJZ5=2,H*1.02,'⑶'),COLOR0000FF;
DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.98,'⑷'),COLOR0000FF;
DRAWTEXT(EX2 AND (PL10>REF(PL10,1) OR REF(PL10>REF(PL10,1),1) OR ZTJD10=1),H*1.08,'⑸'),,COLOR0000FF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.06,'①'),LINETHICK3,COLOR00FFFF;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L*0.94,'②'),LINETHICK3,COLOR00FFFF;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2,H*1.06,'③'),LINETHICK3,COLOR00FFFF;
DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3,L*0.94,'④'),LINETHICK3,COLOR00FFFF;
XG1:=EX2;{WWW.GPXIAZAI.COM}
XG2:=PL20>REF(PL20,3);
XG3:=ZTJZ10=3;
DRAWTEXT(REF(XG2*XG3,1) AND XG1,H*1.06,'⑤'),LINETHICK3,COLORWHITE;
DRAWTEXT(REF(XG2*XG3,1) AND XG1,H*1.04,'●'),LINETHICK3,COLORFFFF00;
DRAWTEXT(REF(XG2*XG3,1) AND XG1,H*1.02,'●'),LINETHICK3,COLOR00FFFF;
買線:=EMA(C,2),COLORRED;
賣線:=EMA(SLOPE(C,21)*20+C,42),COLORYELLOW;
BU:=CROSS(買線,賣線);
SEL:=CROSS(賣線,買線);
STICKLINE(買線>=賣線,CLOSE,OPEN,3,0),COLORRED;
STICKLINE(買線>=賣線,LOW,HIGH,0,0),COLORRED;
STICKLINE(買線<賣線,CLOSE,OPEN,3,0),COLOR00FFFF;
STICKLINE(買線<賣線,LOW,HIGH,0,0),COLOR00FFFF;


後台-系統-系統設置-擴展變量-(内容頁告位2-手機版)
聲明:本文内容由互聯網用戶自發貢獻自行上傳,本網站不擁有所有權,未作人工編輯處理,也不承擔相關法律責任。如果您發現有涉嫌版權的内容,歡迎發送郵件至本站聯系郵箱進行舉報,并提供相關證據,工作人員會在5個工作日内聯系你,一經查實,本站将立刻删除涉嫌侵權内容。
後台-系統-系統設置-擴展變量-(内容頁告位3-手機版)